Moderation Dashboard - Delay in processing
Incident Report for Hive
Resolved
This incident has been resolved.
Posted Jun 06, 2023 - 21:25 PDT
Investigating
New task submissions to the moderation dashboard are still being accepted, but are having delays in processing.
Posted Jun 06, 2023 - 13:15 PDT