Domain Name Registration

Incident Report for Hive

Postmortem

Our domain registrar had a bug which invalidated our domain renewal. We’ve resolved the issue and are now implementing back-up domains in the future

Posted Mar 17, 2025 - 05:02 PDT

Resolved

We are currently investigating this issue.
Posted Mar 17, 2025 - 01:00 PDT